Scheduled for 26 Jan, 2026 at 7:00 PM – 7:45 PM
Completed
26 Jan, 2026 at 7:45 PMCompleted
26 Jan, 2026 at 7:45 PMMaintenance has completed successfully
In progress
26 Jan, 2026 at 7:00 PMIn progress
26 Jan, 2026 at 7:00 PMMaintenance is now in progress
Planned
26 Jan, 2026 at 7:00 PMPlanned
26 Jan, 2026 at 7:00 PMWe are going to be undertaking network system upgrades on our core infrastructure. During the maintenance, some systems may not be accessible for a short time while the upgrades take place. Thank you for your understanding.